Open Office, TortoiseSVN

(Forskjell mellom sider)
Gå til: navigasjon, søk
m (nei vel, ingen __TOC__ i dag :()
Linje 1: Linje 1:
 +
TortoiseSVN er en Windows Shell Extension for [http://en.wikipedia.org/wiki/Subversion_(software) Subversion].
 +
Dette er et gratis program gitt ut under GNU Lisensen(General Public License). Programmet er et versjonskontrollsystem.
 +
Det vil si at det kan holde orden på forskjellige versjoner av datafiler. Når man foranderer på filer som er sjekket inn i subversion, blir de gamle versjonene lagret i databaser.
 +
På denne måten kan man gå tilbake og sammenlikne med tidligere versjoner.
 +
For mer informasjon, les [http://no.wikipedia.org/wiki/Versjonskontrollsystem  wikipedia sine sider om Versjonskontrollsystem].
  
== Hva er OpenOffice ==
 
  
OpenOffice er gratis kontorpakke som kan brukes på windows, linux og solaris. OpenOffice inneholder blant annet:
 
  
{| style="width:300px; height:200px" border="1"
+
==Komme igang==
|-
+
Det beste stedet for å lære seg mer om TortoiseSVN er å gå til hjelp menyen. Dette gjør du ved å klikke på høyre musetast inne i en mappe.
| '''Navn''' || '''Beskrivelse'''
+
Hvis TortoiseSVN er installert, skal det være en egen rad i menyen ved navnet TortoiseSVN. Gå inn her og trykk på Help. Dette vises i bildet under.
|-
+
| WRITER || Tekstbehandler
+
|-
+
| CALC || Regneark
+
|-
+
| DRAW || Tegneprogram
+
|-
+
| IMPRESS || Presentasjonsprogram
+
|-
+
| MATH || Likningseditor
+
|-
+
| HTML || Webeditor
+
|}
+
  
 +
[[image:TortoiseSVN_help.png]]
  
  
== Hvordan komme igang ==
+
==Repository==
 +
Repository på norsk betyr oppbevaringssted. Men vi blir bruke den engelske terminologien gjennom denne guiden.
 +
I de følgende seksjonene vil enkel bruk av programmet forklares. 
 +
=== Opprette ===
 +
Vi skal gå gjennom et enkelt eksempel for å vise hvordan man oppretter en "repository". Først Oppretter du en mappe. Finn et passende sted hvor du oppretter en ny mappe med et passende navn. F.eks. kan den hete "SVNRepository". Deretter høyreklikk på den nye mappen og velg TortoiseSVN → Create Repository here.
  
=== Starte OpenOffice Writer ===
+
[[image:TortoiseSVN_repository.png]]
For å starte OpenOffice Writer (versjon 2.3.0), skriv "ooffice" i et terminal vindu og trykk 'enter'. Det kan lønne seg å sette på "&" etter "ooffice" slik at det fortsatt er mulig å bruke terminalvinduet.
+
  
[[Image:begynn.png|Starte OpenOffice Writer]]
+
Et "repository" blir da dannet i denne mappen.
 +
Ikke gjør endringer på filene som blir opprettet! Disse filene blir brukt og kontrollert av programmet.
 +
=== Layout ===
 +
Før man importerer data til "repository" kan det være greit å bestemme seg hvordan man vil organisere alle filene. Det er noen anbefalte oppsett som kan gjøre det enklere for deg holde oversikten. Men man kan alltid forandre filstruktur når som helst. Her kan man bruke egen sunn fornuft. Et eksempel som er gitt i guiden er gitt av følgende mapper i "repository":
 +
* Prosjektnavn/trunk - Hovedfiler for utvikling av prosjekt.
 +
* Prosjektnavn/branch - Inneholder "branch"-kopier.
 +
* Prosjektnavn/tag - Inneholder "tag" kopier.
  
 +
Denne seksjonen er under utvikling November 2010.
  
For å starte OpenOffice (versjon 3.1.0), skriv "soffice" i et terminal vindu og trykk 'enter'. Det kan lønne seg å sette på "&" etter "soffice" slik at det fortsatt er mulig å bruke terminalvinduet.
 
  
[[Image:OO-terminal.png|Starte OpenOffice Writer v3.1.0]]
+
==Mer info==
 +
===Eksterne lenker===
 +
[http://tortoisesvn.tigris.org/ Offisiell hjemmeside]
  
Du får da opp følgende side, hvor du kan velge hva slags dokument du vil begynne å lage.
 
  
[[Image:OO-start.png|Startside for OpenOffice v3.1.0]]
 
  
 
+
[[Kategori:Programvare]]
 
+
[[Category:Windows]]
=== Nytt tekstdokument ===
+
Etter kommandoen "ooffice" vil det dukke opp et rimelig blankt vindu. For å opprette et tekstdokument, klikk på følgende:<br>
+
'''File''' -> '''New''' -> '''Text Document'''
+
 
+
{|align="left"
+
|[[Image:Nytt_dok.png|500x650px|Opprette et nytt tekstdokument]]
+
|}
+
{|align="left"
+
|[[Image:Tomt_dok.png|500x650px|Et tomt tekst dokument]]
+
|}
+
 
+
<br clear="all" />
+
 
+
 
+
 
+
=== Lagre fil ===
+
'''File''' -> '''Save'''
+
Det finnes derimot et annet alternativ som heter '''Save as..''', der du får muligheten til å lagre en eksisterende fil med et annet navn. Dette er nyttig hvis du har åpnet en gammel rapport for kun å bruke mal'en og ikke endre den.
+
 
+
Når du har klikket på save, vil det komme fram følgende vindu:
+
 
+
[[Image:lagring.png|600x450px|Lagre til fil]]
+
 
+
Trykk på "Browse for other folders" for å finne mappen du vil legge dokumentet i.
+
Skriv ved siden av "Name" det navnet du ønsker at filen din skal hete. Under "File type" finner man de forskjellige formater en fil kan lagres på. ".sxw" er en vanlig OpenOffice Writer format for den gamle versjonen 1.1.5 . For versjon 2.0.3 finner man i tillegg en OpenOffice Writer format som heter ".odt". Denne er en nyere format og kan innholde ting som ikke støttes av 1.1.5, men er det er dette formatet som nå er vanlig.
+
 
+
 
+
 
+
==== Lagre i pdf-format ====
+
'''File''' -> '''Export as PDF'''
+
Et liknende vindu som ovenfor vil da dukke opp.
+
 
+
 
+
 
+
== Format ==
+
[[Image:format.png|500x650px|Format meny]]
+
 
+
* '''Default''' : Endre alt tilbake til OpenOffice Writer sin standard innstilling.
+
* '''Character''' : Gir muligheten for endring av "Font" mtp skrift type, størrelse, farge, dreining, superscript osv.
+
* '''Paragraph''' : Egeninnstilling av paragrafer som avstander, linjeskift osv.
+
* '''Bullets and Numbering''' : For å lage punktliste og nummerering.
+
* '''Page''' : Kan endre egenskaper til skrivearket. Eks. marg, landscape, størrelsen på arket, header, footer osv.
+
* '''Change Case''' : For å endre små bokstaver til store og vice versa.
+
* '''Columns''' : Har kan man splitte opp skrivearket i kolonner.
+
* '''Styles and Formatting''' : For å velge forhåndsbestemt formattering for like overskrifter osv.
+
* '''AutoFormat''' : Setter tekst til AutoFormat. En kan velge mellom at den automatisk gjør det mens man skriver, eller en kan gå igjennom etterpå og godkjenne hver endring.
+
* '''Anchor''' : til å lage en link.
+
* '''Wrap''' : Hvordan teksten skal omkranse valgt objekt (for eksempel ett bilde).
+
* '''Alignment''' : Stilling på tekst eller objekt, høyrestilt osv.
+
* '''Arrange''' : Kan brukes til å legge objekter og tekst oppå hverandre.
+
* '''Flip''' : Roterer.
+
* '''Group''' : Grupperer.
+
* '''Object''' : Kan endre objektets størrelse og andre egenskaper.
+
 
+
 
+
=== Marg ===
+
For å endre størrelsen på skrivearket:
+
'''Format''' -> '''Page'''
+
Under "Borders" kan man definere avstandene mellom kanten av arket og inn til skriveområdet. "Header" og "Footer" gir topp- og bunntekst. under "Background" kan du endre bakgrunsfarge.
+
 
+
 
+
 
+
== Insert ==
+
Inne i denne menyen finnes blant annet:
+
* '''Fields''': Lage nummereringer for f.eks. captions
+
* '''Special Characters''': Innsetning av forskjellige tegn og symboler i varierte skrift-type
+
* '''Header''': Lage en tekst i toppen av alle skrivearkene
+
* '''Footer''': Lage en tekst i bunnen av alle skrivearkene
+
* '''Indexes and Tables''': Sette inn tabeller av ønsket størresle
+
* '''Picture''': Importere bilder fra fil
+
* '''File''': Importere innholdet til en fil
+
 
+
 
+
== Bilder og Figurer ==
+
For å lime inn bilder og figurer:
+
Insert -> Picture -> From file
+
 
+
Ytterligere endringer kan gjøres med bildet ved å dobbelklikke på figuren.
+
 
+
=== Caption og nummerering ===
+
Det er alltid nyttig å gjøre bilder mer meningsfullt ved å sette inn Captions. En tekst under et bilde.
+
høyreklikk på bilde -> Caption
+
 
+
[[Image: caption.png|500x500px|Sette til caption på bilde/figur]]
+
 
+
Under "Category" kan man sette inn et navn til den type bilde det måtte falle i smak. F.eks. illustration, graf, histogram osv. Dette har derimot en ekstra effekt for referering. Man kan legge merke til at det lages et tall som har grå bakgrunn etter "Illustration" under bildet. Dette tallet varieres ettersom hvilken rekkefølge av sin egen Category den ligge i. Dvs. at hvis det importeres et bilde før den nåværende med samme kategori (Illustration), så vil tallet endres til 2.
+
 
+
For å lage sine egne "varierende tall":
+
Insert -> Fields -> Other
+
 
+
 
+
 
+
== Tabell ==
+
Insert -> Indexes and Tables
+
Alternativ: Hos standard oppsett ligger det allerede et ikon på sidebar, vis i figuren under, som det er mulig å klikke på. Det er derimot to måter å bruke det ikonet på. Vanlig klikk (1) eller holde musknappen nede (2).
+
 
+
# Et vindu dukker opp, og man må skrive inn rad og kolonne.
+
# En mer detaljert insert-meny dukker opp. Hvis man holder museknappen nede på "Table" igjen, glis et rutenett. Med rutenettet kan du styre og velge størreslen på tabellen med musa.
+
 
+
 
+
[[Bilde:tabell.png|500x400px|Innsetning av tabell]]
+
 
+
 
+
 
+
== Matematiske formler ==
+
OpenOffice har muligheten til å lage matematiske formler textbasert. Eks. "sqrt(2)" for <math>\sqrt{2}</math>, "int from 0 to 1" for <math>\int_{0}^{1}</math> osv. .
+
 
+
'''Insert''' -> '''Object''' -> '''Formula'''
+
Etter en kort stund vil det dukke opp et vindu i dokumentet hvor det er mulig å skrive inn formel, vist i figuren under. Itillegg åpnes et annet verktøysvindu som heter '''Selection''', der man har muligheten til å klikke seg fram til forskjellige tegn og funksjoner. En tekst vil dermed dukke opp i formel-vindu og dette representerer altså funksjonen. Om ikke '''Selection'''-vinduet kommer fram automatisk, kan den åpnes igjen ved:
+
'''View''' -> '''Selection'''
+
Det er verdt å merke seg at menyene fra normal modus (før du går inn i "Formula"), som f.eks. format, er annerledes. For å gå tilbake til vanlig visning trykker du bare på dokumentet ved siden av formelen.
+
 
+
[[Bilde:formel1.png|400x500px|Menyene i Formula]]
+
 
+
 
+
Det er fullt mulig å lage fine formler med OpenOffice, og det lønner seg å sette seg inn i kommandoene i "Selection".
+
 
+
For å komme ut av Formel-modus. Klikk på et sted på skrivearket der formelen ikke er.
+
 
+
 
+
 
+
== Utskrift ==
+
En sikker måte å printe ut filen på, som er en "work-around"-måte, er å lagre filen som *.pdf, og deretter bruker "print" fra terminalvindu.
+
Se: [[#Lagre i pdf-format|Lagre i pdf-format]]
+
print <filnavn>
+
 
+
Fargeprinteren på VB har av og til problemer med å printe i farger fra tekstbehandleren OpenOffice Writer. Dette kan løses ved å gå på ''File'' -> ''Printer Settings'', velge vbfarge, trykke ''Properties'', gå inn på fanen ''Device'' og sette ''Color'' til ''Color'' istedet for ''from driver''.
+
 
+
 
+
== Stavekontroll ==
+
For å aktivere stavekontroll, må man først angi språket i dokumentet
+
Verktøy -> Språk -> For all tekst -> ''Norsk bokmål''
+
Tools -> Language -> For all text -> ''English''
+
 
+
Deretter kan man aktivere stavekontroll ved å trykke på ikonet på oppgavelinja (det til høyre):
+
[[Bilde:OO_Stavekontroll_ikon.png]]
+
For å starte gjennomgang av stavekontrollen, trykk '''F7'''.
+
 
+
 
+
 
+
== Snarveier og Hotkeys ==
+
Egendefiner hotkeys ved:
+
Tools -> Customize
+
 
+
== Relevante linker ==
+
* [http://www.openoffice.org/ OpenOffice sin offisielle hjemmeside]
+
 
+
[[Category:Programvare]]
+
[[Category:Tekstredigering]]
+
[[Category:Kontorprogramvare]]
+

Revisjonen fra 25. nov 2010 kl. 19:39

TortoiseSVN er en Windows Shell Extension for Subversion. Dette er et gratis program gitt ut under GNU Lisensen(General Public License). Programmet er et versjonskontrollsystem. Det vil si at det kan holde orden på forskjellige versjoner av datafiler. Når man foranderer på filer som er sjekket inn i subversion, blir de gamle versjonene lagret i databaser. På denne måten kan man gå tilbake og sammenlikne med tidligere versjoner. For mer informasjon, les wikipedia sine sider om Versjonskontrollsystem.


Innhold

Komme igang

Det beste stedet for å lære seg mer om TortoiseSVN er å gå til hjelp menyen. Dette gjør du ved å klikke på høyre musetast inne i en mappe. Hvis TortoiseSVN er installert, skal det være en egen rad i menyen ved navnet TortoiseSVN. Gå inn her og trykk på Help. Dette vises i bildet under.

TortoiseSVN help.png


Repository

Repository på norsk betyr oppbevaringssted. Men vi blir bruke den engelske terminologien gjennom denne guiden. I de følgende seksjonene vil enkel bruk av programmet forklares.

Opprette

Vi skal gå gjennom et enkelt eksempel for å vise hvordan man oppretter en "repository". Først Oppretter du en mappe. Finn et passende sted hvor du oppretter en ny mappe med et passende navn. F.eks. kan den hete "SVNRepository". Deretter høyreklikk på den nye mappen og velg TortoiseSVN → Create Repository here.

TortoiseSVN repository.png

Et "repository" blir da dannet i denne mappen. Ikke gjør endringer på filene som blir opprettet! Disse filene blir brukt og kontrollert av programmet.

Layout

Før man importerer data til "repository" kan det være greit å bestemme seg hvordan man vil organisere alle filene. Det er noen anbefalte oppsett som kan gjøre det enklere for deg holde oversikten. Men man kan alltid forandre filstruktur når som helst. Her kan man bruke egen sunn fornuft. Et eksempel som er gitt i guiden er gitt av følgende mapper i "repository":

  • Prosjektnavn/trunk - Hovedfiler for utvikling av prosjekt.
  • Prosjektnavn/branch - Inneholder "branch"-kopier.
  • Prosjektnavn/tag - Inneholder "tag" kopier.

Denne seksjonen er under utvikling November 2010.


Mer info

Eksterne lenker

Offisiell hjemmeside

Personlige verktøy
Navnerom
Varianter
Handlinger
Navigasjon
Kategorier
Programvare
Andre
Translate
Verktøy